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Tutorial 19: Exporting from the Database

You may wish to export your search results so that you can visualise or conduct analyses of your
results in other programs, such as in a spreadsheet or GIS software.

In this tutorial we will learn how to export search results from the database into a .csv or
shapefile format, and how to make some adjustments to the exported files to make them easier
to work with.

1 Getting Started

Use the simple or advanced search to filter search results to your specifications.

e Refer to Tutorial 1, Tutorial 1b, and Tutorial 17 for more detailed instructions on
searching.

2 Exporting your Search Results

When you have filtered your results to your specifications, click on the Export icon in the upper
right corner of the Search page (Figure 1).

e The instructions in this tutorial will work for any type of record (Resource Model).

o However, it is only possible to export one type of record (Resource Model) at a time, for
example ONLY Heritage Places or ONLY Information Resources.

e [fyour search results contain multiple record types, you should use the ‘Resource Type’
dropdown below the search bar to filter your records by Resource Type and do separate
downloads for each type, e.g. one download for Heritage Places and then a separate
download for Information Resources.
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This will open the export window (Figure 2).
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e Choose which format you would like your results to be exported as - csv or shapefile.
e Specify how many decimal places you would like geographical co-ordinates to be precise

to.
o The default is six places. This should normally be fine to leave as it is and will
provide accuracy below 1 m.
Click Download.

e Rename your file to something memorable and save it to your computer in your chosen
location using the window that opens.
The file will be saved as a .zip file.

e Use unarchiving software (e.g. 7zip) to unzip the file and access the .csv or shapefile.

3 Working with a CSV export

You can open and view the information in your .csv file with spreadsheet software such as
Microsoft Excel, OpenOffice Calc, or by uploading it online into Google Sheets.

When you open the document, you will see that the columns (i.e. that database fields) are in a
random order. If you want to change the order of the columns you have two options:

1. Rearrange the columns manually to an order than makes sense to you.
2. Use one of our pre-set documents to change the order of the columns to something that
more closely resembles their order in the database.
a. Please note that the pre-set documents referred to in below ONLY work for
Heritage Place exports.
b. Separate documents will be produced for different types of resources. When
they are available, they will work the same way as the instructions below.
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To follow the second method, you must use either Microsoft Excel or Google Sheets. We are
currently working on making this available in OpenOffice Calc, but this is still in development.

3.1 Microsoft Excel method

Download the ‘EAMENA Reorganise Export Columns.xlsm’ file from the training website and
save it to your computer.

e Open the file, and when you see a message or warning about macros, click ‘Enable
content’ or ‘Enable macros’ (Figure 3).
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e Open your .csv export file in Microsoft Excel.
e Inyour .csv file, right click on the sheet with the data in it and choose ‘Move or Copy’
(Figure 4).
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Figure 4

e Change the dropdown under ‘To book:’ to the ‘EAMENA Reorganise Export
Columns.xlsm’.
Make sure ‘Create a copy’ is ticked.

e C(lick ‘OK’ (Figure 5).
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Create a copy
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Figure 5
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e This will create a copy of the sheet in the Reorganising document (Figure 6).
o You can delete Sheetl, but this is optional.
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Figure 6

e (o to the ‘View’ Tab and click on ‘Macros’ (Figure 7).
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. . " ) .
e Inthe window that appears, click on the Macro called ‘moveColumns’ and then click
1 ) .
Run’ (Figure 8).
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e Inthe next window that appears, enter the name of the sheet that you copied from the

csv and that you want to be reorganised, and then click OK (Figure 9)
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Figure 9

e Anew tab will be created called ‘Final Report’ which will contain the same data but with
the columns rearranged.



EAMERNR

Endangered Archaeology in the Middle East & North Africa

3.2 Google Sheets method

Open your .csv export file in a spreadsheet application such as Microsoft Excel or OpenOffice
Calc on your computer.

Open the Google Sheets Column Reorganiser in an internet browser at (Figure 10):
https://docs.google.com/spreadsheets/d/1CMaWxaHPgZvv]5SDh1BQV6hiBYrtR4Vvd7bOAd4g
oCo/edit?usp=sharing

EAMENA_Export_Column_Reorganiser ¥ 1 & a 8
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o~ @ P 100% » £ % 0 00 123+ Calibri ~- 12 - B I S5 A & H S t-3-y B WY ~ZI- ~ [
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1
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5 Nichole Sheldri GEOMETRYCOL  08/02/2019 Positive/Built |

6 Nichole Sheldri GEOMETRYCOL ~ 08/02/2019 Negative/Cut/

7 Nichole Sheldri GEOMETRYCOL ~ 08/02/2019 Positive/Built |

8 Nichole Sheldri GEOMETRYCOL  08/02/2019 Positive/Built |

] Nichole Sheldri GEOMETRYCOL ~ 08/02/2019 Positive/Built |

10 Nichole Sheldri GEOMETRYCOL  08/02/2019 Positive/Built |

n Nichole Sheldri GEOMETRYCOL ~ 08/02/2019 Positive/Built |

12 Nichole Sheldri GEOMETRYCOL  10/02/2019 Positive/Built |

13 Nichole Sheldri GEOMETRYCOL ~ 10/02/2019 Positive/Built |

1 Nichole Sheldri GEOMETRYCOL ~ 10/02/2019 Positive/Built |

15 Nichole Sheldri GEOMETRYCOL  10/02/2019 Surface Featur

16

17

18

19

20

21

+ = Original ~ B exviore >
Figure 10

When you have opened the document, there should be one tab called ‘Original’ and there may
already be data in the spreadsheet as in Figure 10.

e C(lick on 'File > Make a Copy’ and make a copy of this document and save it in your own
Google Drive.

In your new version of the document, if there are any additional tabs, you should delete them
first.

e (o to your original .csv export document and select and copy the data that you want to
rearrange.

e Paste itinto the ‘Original’ tab of the EAMENA_Export_Column_Reorganiser document in
your browser.


https://docs.google.com/spreadsheets/d/1CMaWxaHPgZvvJ5SDh1BQV6hiBYrtR4Vvd7bOAd4goCo/edit?usp=sharing
https://docs.google.com/spreadsheets/d/1CMaWxaHPgZvvJ5SDh1BQV6hiBYrtR4Vvd7bOAd4goCo/edit?usp=sharing
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Click on ‘Tools > Macros > moveColumns” (Figure 11).
C @& docs.google.com/spreadsheets/d/1CMaWxaHPgZvvJ5SDh1BQV6hiBYrtR4Vvd7bOAd4goCofedit#gid=0 a % O * ﬁ- H
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EAMENA_Export_Column_Reorganiser ¢ @ (=] ﬁ_
File Edit View Insert Format Data Tools Add-ons Help Lasteditwas yesterdayat15:37
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Heritage Place Resource Instance © AppSheet >
A ) o F G " 1 J K L M
Heritage Placel icPlz «> Script editor \cc Imagery Acquis Maximum DepiTidal Range  Detailed Condif Threat Cause T Depositional Pr Spatial Coordin Overall Site M
Nichole Sheldri GEOMETRYCC . . Positive/Built |
Nichole Sheldri GEOMETRYCC © Record macro Negative/Cut/ (/]
Nichole Sheldri GEOMETRYCC Spelling N Manage macros Positive/Built |
Nichole Sheldri GEOMETRYCC ot Positive/Built |
Nichole Sheldri GEOMETRYCC + Enabl Negative/Cut/
Nichole Sheldri GEOMETRYCC navie Positive/Built |
P moveColumns
Nichole Sheldri GEOMETRYCC Notification rules Positive/Built |
Nichole Sheldri GEOMETRYCC Protect the sheet Positive/Built |
Nichole Sheldri GEOMETRYCC Positive/Built |
Nichole Sheldri GEOMETRYCC - Accessibility settings Positive/Built |
Nichole Sheldri GEOMETRYCC . __, ., . __ Positive/Built |
Nichole Sheldri GEOMETRYCOL ~ 10/02/2019 Positive/Built |
Nichole Sheldri GEOMETRYCOL ~ 10/02/2019 Positive/Built |
Nichole Sheldri GEOMETRYCOL ~ 10/02/2019 Surface Featur
+ = Original = Explore >
Figure 11
The first time you do this, it will ask for your permission to authorise the macro
Click Continue (Figure 12).
Authorisation Required
A script attached to this document needs your permission to run.
Continue Cancel
Figure 12
Click on your Google account (Figure 13).
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‘00 @ Sign in — Google accounts

@ accounts.google.com/o/oauth2/auth/oauthchooseaccount?client_id=874269840...

G Sign in with Google

Choose an account

to continue to Recorded macros (EAMENA_Export_Macro)

Nichole Sheldrick
" ensheldrick@gmail.com

® Use another account

English (United Kingdom) ~ Help Privacy Terms

Figure 13

Then click ‘Allow’ (Figure 14).

G Sign in with Google

Recorded macros (EAMENA_Export_Macro)
wants to access your Google Account

&— ensheldrick@gmail.com
This will allow Recorded macros (EAMENA_Export_Macro) to:

® View and manage spreadsheets that this application has been @
installed in

Make sure that you trust Recorded macros
(EAMENA_Export_Macro)

You may be sharing sensitive info with this site or app. Find out how Recorded
macros (EAMENA_Export_Macro) will handle your data by reviewing its terms
of service and privacy policies. You can always see or remove access in your
Google Account.

Find out about the risks

Cancel Allow

English (United Kingdom) ~ Help Privacy Terms

Figure 14
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e (lick on ‘Tools > Macros > moveColumns” again to run the macro.
e A new tab will be created called ‘Rearranged’ which will contain the same data but with
the columns rearranged.

You can then work with the data in Google Sheets, or export it to another program, such as
Microsoft Excel or OpenOffice Calc.

4 Working with a shapefile export

Your shapefile can be used in GIS software such as QGIS or imported directly into Google Earth.

e Refer to GIS Tutorials 1, 2, and 3, for more detailed instruction on working with
shapefiles in QGIS.

To import a shapefile into Google Earth Pro:

e Inthe menu, click on ‘File > Import’
o Navigate to the shapefile where you have saved it on your computer.
o You may have to change the ‘File Type’ to ‘ESRI Shape (*.shp)’ (Figure 15).

[ Google Earth Pro
vSearch | W Open n
®© ~ 1 L » ThisPC » Desktop » Morocco-EAMENA v & »
- { Organize~  New folder E v | @ F
v Places Favorites ~  Name Date modified Type
-8e My Places

# O & APAAME Pins Sorted.km
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O ® Gasr Duib
% O & Rural Tripolitania (1Apr1€
@ 0@ Rural Tripolitania
# O & IRT locations
% O & Roads - Barrington Atlas
% O & Tripolitania Sites OLD
% 0 & Jerba_Siteskmz
= 0 © Raw Data
O # 945 masl
= O 8 Analyses (old)
= 0 8 outside Tripolitania
O &» Dartmoor Death March -
# O & Trans-Sahara Tripolitania
# O 8 Tripolitania - NSheldrick
+ B & EAMENA Gridskmz
+ O'& pleiades KML
0 pura Europos 2
O pura Europos 3
+ O 8 Dura Europos
u] Khirbet Faynan, Jordan
=08 ytica
+ 08 Acholla
« 08 canada
« 0@ yg
O @ temporary Places

Il Desktop
J& Downloads

Heritage Place_Geometry_point.shp

¥ Dropbox (Personal)
% Recent places

). Utica

Je= Box Sync

¥ Dropbox (EAMENA)

M This PC
& Desktop
Documents
J4 Downloads

b Mucic e IS

File name: Heritage Place_Geometry_pointshp

Figure 15
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Click on the file in the folder with the .shp file extension and click ‘Open’.
A window will pop up to ask you “Do you want to apply a style template to the features
you ingested?”
o Click ‘Yes'.
Choose ‘Create a new template’ and click ‘Ok’ (Figure 16)

¢ Create new template

Use existing template

Compatible templates

Contour

Figure 16

In the Name tab that opens first, choose the field from the dropdown that has the terms
that you want the sites to be labelled as.
o Werecommend using the ‘EAMENA_ID’ or ‘SiteName’ fields (Figure 17).

.

| Name Color  Icon Height |

Set name field EAMENA_ID [+

This preview table contains the first ten features in the dataset

SurfaceGeo InfResDate Dasig_Typ SiteNamea EAMENA_ID Top

WOEN30_42... | EAMENA-00... | Plain/F

WO0BN30_42... | EAMENA-00...  Summ

WO06EN30_42... | EAMENA-00Q...  Summ

WOEN30_42... | EAMENA-00... | Summ

WO0EBN30_42... | EAMENA-00... | Slopes

Cancel

Figure 17
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Click on the ‘Color’ Tab and choose from the three options.
o ‘Use single color’ will apply the same colour for all of the pins that are created.
= (Click on the colour box beside it open the colour wheel and choose your
colour (Figure 18).

@ ® Style Template Settings
Name [CEEH icon  Height

Set color from field
© Use single color [l

Use random colors

This preview table contains the first ten features in the dataset

Condition AssessType DistCaCert Datum DisturbCat InterpNum

Very Bad Desk-based | Medium Building and ... | Unknown

N oeaaa— Desk-based | Medium Unknown 1
. .=II e e Desk-based | Not Applicable Unknown

Desk-based Not Applicable Unknown

Cancel OK
Desk-based Infrastructur...

Figure 18

o ‘Use random colors’ will apply a random colour to every pin that is created.
o ‘Set color from field’ allows you to choose a field and set a colour for each of the
terms that are present in that field.
= Choose the field you want to sort by in the ‘Select color field’ dropdown.
*  You will see a list of the terms and the number of records that have that
term in the ‘Bucket options’ window below.
= Set the ‘Palette start color’ and ‘end color’ to create a palette of colours
you want to choose from.
= Change the colour applied to each individual term in the ‘Bucket options’
window.
= (Click the option to ‘create sub-folders for each bucket’ if you want your
pins to be sorted into folders based on this criteria and specify the folder
names (Figure 19).

13
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[ JoN | Style Template Settings
LNETGC Color EGED Height

© Set color from field
"1 Use single color

"I Use random colors

Select color field Condition B
Palette start color [ end color, [ NN S

create sub-folders for each bucket

Bucket options

Color  Condition Folder name Count
Reverse order
Fair Fair 16
[ | Poor Poor 15
BB VeryBad Very Bad 6
BB cood Good

This preview table contains the first ten features in the dataset

Condition AssessType DistCaCert Datum DisturbCat InterpNum RoleType
1 VeryBad Desk-based Medium Building and ... | Unknown
2 Poor Desk-based Medium Unknown 1
3  Good Desk-based Mot Applicable Unknown 1
4 Fair Desk-based Not Applicable Unknown 1
5 Fair Desk-based Medium Infrastructur... |1
BEIE  cancel
Figure 19

Click on the ‘Icon Tab’ to select the type of icon you want to use for each of your pins.
o ‘Use same icon for all features’ will apply the same icon to each pin, with the
colours you specified in the ‘Color’ tab.
o ‘Seticon from field’ will allow you to choose a field and set a different icon for
each unique term that appears in the field.
* Use the same instructions as in ‘Color’ tab to set different icons.
Click on the ‘Height’ Tab to change the height that the pins are set at.
o ‘Clamp features to ground’ is the normal default.
o ‘Setheigh from field’ will allow you to set a different height based on each
unique term that appears in the field.
* Use the same instructions as in ‘Color’ tab to set different heights.

When you have set your parameters, click ‘Ok’.

Save the ‘Style Template’ in the window that opens.
Click ‘Save’.

Your pins will appear in your ‘Temporary Places’ folder.
Move it to the ‘My Places’ folder to ensure it is saved.
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e Your pins will appear with the settings you have specified, divided into folders if you
have indicated this, and each record will all of the information contained in the attribute
table of the shapefile (Figure 20).

¥ Search | E (¥ |o' | e e @ A-H@ ‘_F_

‘ Search I

ex: Hotels near JFK

Get Directions History

¥ Places |

> B2 TUNISIA
» EE TRIPOLITANIA (Sheldrick 2016)
» @5 LBYA
1B EGYPT
[ 1ED ISRAEL
B2 PALESTINE
[ /B2 LEBANON
/B2 SYRIA
/B2 JORDAN
B2 SAUDI ARABIA
/B2 YEMEN
B omMAN
| /B2 UNITED ARAB EMIRATES
B QATAR
[~ /B BAHRAIN
B3 KUWAIT
» B IRAQ
» | |E IRAN
» [|E) OTHER (APAAME)
» | |ED North African Rock Art
3~ Heritage Place_Geometry_point.shp
53 Heritage Place_Geometry_point
v S Very Bad
© 9 EAMENA-0056730
© 9 EAMENA-0056478
@9 EAMENA-0056536
@9 EAMENA-0056175
@9 EAMENA-0056429
@9 EAMENA-0056432

YYVYVVYVVVVYVYYY

» @5 Poor

» @5 Good

> B Fair
[ . [ 7| PN~
¥ Layers |
¥ & Primary Database m

B3 Announcements
> P Borders and Labels
[ Places

4 FeatArma

Morphology Surface Feature

SiteShape  Unknown

CalDateFro

Condition  Very Bad

AssessType Desk-based
Medium

Building and Development
Unknown

CalDateTo

Islamic (North Africa), Islamic (North
Period Islamic iNom Mrlea} Islamic g‘loﬂh
Function

Possible, Possible, Possible, Possible
Unknown

Not Applicable

Unknown

Morocco

Not Applicable
Colour/Texture Difference

Medium

HrtgPl_Typ
LandCover
Unknown

Figure 20

PP
P
R EAMENA-0055986
NA-0055922

»EAMENA-00564294

PEAMENA-00564
056299, EAMENA-00S5

ENA-0056477
AZ005648HAMENA-0056478
S22 ¢ AMENA 0056502
6356 %
EAMENA=0056536

AMENA-0056556

¥ 4

I~ o :
Google Earith

Imagery/Date:/6/27/2020 lat 30:6501532" lon -6:1811212 elev. Om eyealti28:69 km

Refer also to GIS Tutorial 6, Section 2.2 for another example of importing a shapefile into Google

Earth.
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5 Working with exported data

There are a few important things to remember when working with exported data in
spreadsheet format or in a shapefile.

e The information contained in each individual record is only a list of all the terms that
have been identified in that record in each field.

e Many of the relationships between individual terms within a record may have been lost.
It is not possible to be certain, for example, which Cultural Period belongs with which
Cultural Sub-Period, without checking in the database.

o Therefore, it is possible to do analyses which measure whether a term is present or
absent in a record, but not to do analyses which rely on any of these relationships being
correct.

e A way to improve the quality of the exported data is currently in development.

If you want to do complex data searches, we recommend that you do this in the database itself,
using the Advanced Search Function, and do not do them using exported data.
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